Anyone knows how the 12V system works?

12v
twizy
charging

(Pollus Fornerod) #1

I’ve got my second hand Twizy three weeks now, and there is one thing that keeps bugging me. The 12V battery does not charge when the car is plugged in, and only starts to charge when I am driving at a higher speed. Which means that at EVERY traffic light the battery fault light comes on with a beep, only to dim when I am driving again. And that annoys me…

This evening I noticed something peculiar. While driving on a small country lane I saw my headlights burn brighter when I push the “gas” peddle. At that moment I hear a click like some relais comes into action and my battery-monitor-sigarette-ligther-thingy shows three LED’s, which indicates the 12V battery is charging at the specified rate.

The moment I let go of the peddle, I hear the relais click again, the headlights burn noticeably dimmer and the battery-thingy only shows one LED, indicating that the (new!) 12V battery is now delivering power without being charged.

I cannot find any electrical schema of the Twizy so I do not know how those 58V to 12V DC-DC converter is connected. I even do not know where that 12V is generated (is it done by the charger, or is it done somewhere in the large battery box?)

So is there anyone who can help me locate the problem? Anyone with some knowledge about the Twizy Electronics? Any help appreciated!

Greetings from Holland!
Pollus


(Richard) #2

I had the exact same problem. The 12v battery discharge light on the dash came on when stopped at traffic lights or when driving slowly, but when you accelerated hard it would go off and stay off for a while - I assumed it was charging the 12v. Renault tried a number of things to fix it. They did a reboot of the system by removing the fuses. This did not work. I asked them to check for loose connections, which they assured me they did.

The bad news is that i ended up replacing the charger. Renault helped with the cost even though the car was out of warranty which was welcome. Replacing the charger solved the problem.

From this it would suggest that the 12v charge circuit is part of the main charger, but I cannot be more specific.

Richard


(Pollus Fornerod) #3

Hi Richard.

I just went by the Renault garage to show the error and they told me it needs probably a new charger which costs a little over 1000 euro’s. Throwing money at problems usually works but I want to try first a different route, especially since this 2012 Twizy is out of any guarantee or goodwill programme.

The point is that I cannot escape the feeling that it is just something simple, a faulty 2€ component or just a bad contact. Because if it charges, it charges allright.

Another interesting observation is that if I drive it hard, like 10m minutes @ max speed, the 12V charger stays on, even at stand still. So it could even be a thermal problem, some contact that gets made if some other component gets hot (which - now I think of it - also occurs when you push the pedal, but then temporarily).

The problem is, any information is missing right now to determine which component is playing up… So, since in this group people are building their own battery packs and custom BMS’ses, i hope somewhere out there are people that can help me solve this puzzle.

Meanwhile I try to get used to the beeping warning sign, keeping in mind the one positive thing of the limited range of a Twizy: you are never far from home if it breaks down :slight_smile:

Pollus


(osbrook) #4

If it is thermal expansion./contraction as you suggest then the 12v Charging circuit would work after the main Traction charger has been on for a few minutes as it would get warm then.

Perhaps a visual scan of the charger is worth doing. It is under your feet. Remove the mats and then take out the floor panel and you will see the unit.


(Richard) #5

Pollus,
I agree, I was pretty convinced that it was something simple like a sticking solenoid but did not have the time to investigate. I even asked for the old charger back following the work but they said that was not possible as the replacement was heavily discounted.

As you say, someone out there must know.

Good luck


(Bas) #6

As far as I know and has been confirmed by Renault mechanics, the 12V battery must charge when the car is plugged in, which is also the reason the fan of the transformer continues to run for a while even after the car has been fully charged. This is because it takes more time to charge the 12V battery and therefore the transformer continues to run. Apart from this the 12V battery is only occasionally charged by the traction battery as you have very well found out and this to me seems as if the car is behaving normally, the problem in your case is that the light comes on because the 12V battery was not charged to begin with.

To me this sounds like a defect in the charger unit. In fact, I would be curious to hear whether the fan of your charger continues to run even after the Twizy has been completely charged. If it does not this could be another strong indicator that there is something wrong with the charger unit.

To be sure you could try to contact the producer of the charger unit and see if they reply:
0aea391609cb43c56f1a3f28b870543daefbd412_1_666x500

Site:
http://www.ies-synergy.com/en/products/onboard-sealed-chargers/elips-2000w


(Pollus Fornerod) #7

Yup, this really sounds like the charger is the culprit. And it is teasing the hell out of me, for this morning, I started the Twizy and low and behold, all three battery-charging-control-thingy-LED’s came on, indicating the 12V was charging at stand still, and for the first time I drove off without the warning beep!

Unfortunately that miracle only held temporarily. On the way back the battery warning light came on again.

I am tempted to just remove the charger, open it, wiggle some wires, look at the components to see if there is something loose… knowing very well this is not the formal way to check or repair electronics.

Thanks for your replies so far, I keep you posted.