Twizy 2018 Headlights not working


(Paul Matheou) #1

Good evening all,

I just found out both of my Twizy headlights are not switching on. Both sidelights and dip beam working fine. I’ve examined the bulbs through the lens and all seems fine and also checked my fuses they are fine too.

Any ideas as to what the problem is ? The stalk ?

Thank you in advance.

Paul


(Eric Van Loon) #2

Hi Paul,

Are you absolutely sure that the fuse is OK? This is a known weak point of the Twizy. Try switching the fuse with the one below (windshield washer pump).

Kind regards,
Eric


(Paul Matheou) #3

I checked the left and right main beam fuse and there’s no crack in the circuit unless I’m missing something. Would both left and right fuse blow simultaneously?
Thanks for your reply.


(Paul Matheou) #4

Unless I have misread the fuse chart as there’s no other fuses below the two main beam fuses


(Eric Van Loon) #5

Hi Paul,

Check out the main fuse, it’s the fourth one on the top row, the red one. Just switch it with the red one below.

Kind regards,
Eric


(Paul Matheou) #6

You were right all sorted now. I was looking at the individual fuses for left and right and did not look at the main/dip beam fuse.

Thanks for your help.


(Teemu Suikki) #7

My Twizy had the same problem, that exact fuse was blown.

Anyone checked the schematics, is the all headlight current really going through that fuse? 10A fuse really is not enough for two H4’s… 55W/12V = 4.58A, so two bulbs takes over 9A already. Not much of a safety margin to 10A…


(Roel) #8

Yes all the current goes through the fuses. It is even weirder: the current flows through the two 10A fuses in series. So if one blows the (low) beams both stop working. Replace them with 15 or 20A.