Twizy not charging after stalled charge

I charged my Twizy with a gas generator,
idea was to use it as a range extender when you have to fo far without electricity chargers.

Now for some reason the generator stalled and I unplugged. Now the Twizy wont charge but I can drive it.

I spoke to some friends and their tip was that the charger did break.
What are your thoughts of what might be broken?
thnx for help

//Thomas

Thomas welcome to the forum.

Could be that the stall caused a large power spike and the charger has failed. But we are really just guessing. Does the charger make any sounds when you try charging?
Have you checked the fuse in the plug on the Twizy cable? (might be that simple).
Everything is in the Black box under the drives floor panel.
How old is the Twizy as the chargers did change.
Can you let us know how you get on.

When you say fuse in the Twizy cable, is that fuse next to the other fuses or somewhere else?

Hi Osbrook and thank you for helping.
It is a Twizy 2016, I have checked all fuses just where the handbrake is, nothing broken.
There are above all smallfuses two or three large black things that i do not know if it is a relay or a fuse though.

When i try to charge it says click and then nothing, at the same time the groupfuse on my house goes off. Not ground though.

Before the gas generator stalled I had no problem charging and heard the fan kickin in.
I still can drive the car if that is any neccesary onfo. although i have 85%to go and i need to spend those % carefully so I wont have to tow thw Twzy.

In the UK the PLUG on the end of the curly lead has a fuse in it.
image

1 Like

Sounds like part of the charger is working and it’s not an input to the charger fuse.
When the Twizy tries to charge is uses 12V to operate the charging relays. This is the click you hear at the start. Next the fan on the charger cuts in, if it doesn’t there is a problem or you are about to have a problem.

So I’m afraid it is the charger that has failed. Not too hard to replace yourself but not cheap either.

1 Like

Thanks a million for the answer, to cone in the issue makes it easyer to fix it.
Here in Gothenburg, Sweden we only have one dealer, Bilia that takes care of this and they have quite a tasty pricelist. Only for troubleshooting they charge 3000kr~260EUR even if it is only a fuse broken so can you find out by yourself you are lucky.
Hopefully I can find anotherone to repair the charger after demounting it.
I saw that there is a DYI on mounting the charger so Ill use that.

If you can remove the charger and take it to someone who’s good with electronics you may be lucky and get it repaired.

There’s some suppression components on the incoming power supply. Maybe a burnt varistor or something like that.

1 Like

Thanks Peter, I hope I can demount it coming week. I will try to have it fixed by a friend who is electritian. Hopefully he can fix it with guidance from the info in this thread and your guide of how to udemount the charger. thnx a million 4 your help

1 Like

I have now demounted the charger and given it to an electrition so well see how it goes.
Meantime Im searching for used parts and foung second hand charger, but they really do not look like the one I demounted, please help with what it s.

Add images

</direnault_twizy_2013_batteriladdare_h�gsp�nning >

That isn’t a Twizy charge, is it part of the Motor controller?

Jep, Motor controller…

Perhaps this illustration will help?